
Advanced MultiTier Affiliate System

For openCart 3.0.x

Installation Instructions

Works with openCart 3.0.x

1. Either download the .zip and upload it in Admin > Extensions > Installer, or install directly 
from Admin > Marketplace

2. Refresh modifications in Admin > Extensions > Modifications
3. In Admin > Extensions > Modules, click Install, then Edit, configure and Enable

To uninstall:

1. In Admin > Extensions > Modules, click Uninstall
2. Delete entry for .zip in  Admin > Extensions > Installer
3. Refresh modifications in Admin > Extensions > Modifications

If you upgrading from Demo to full version, please uninstall Demo version first.

For technical support please email opencart@phpgods.net with you site information and admin 
access. Include your FTP account information. The module is supposed to work with original 
openCart, and even though compatibility issues are very unlikely to occur, there is no guarantee that
it will work with other extensions, modules, modification or themes.

This module is included in Affiliate Pack X and is compatible with all extensions in the pack.

PLEASE DO NOT POST SUPPORT REQUESTS IN THE OPENCART.COM PAGE COMMENTS!

User Guide
The extension is built around the concept of “affiliate schemes”. Affiliate scheme defines 
commission amounts, which affiliates on each level (up to defined maximum number of 
levels) will receive. You can have unlimited number of schemes, up to 50 levels each.

To define new affiliate scheme, go to  Extensions > Modules > Edit MultiTier Affiliate 
system and click Add button. “Tiers” drop down box sets the maximum number of levels in
the scheme. Set it to anything higher than 1, then scroll down to “Commissions” table. 
The leftmost column, marked Level 1, represents affiliates who signed up at your site 
directly, not under any other affiliate. Level 2 is for affiliates signed up under Level 1, 
Level 3 under Level 2 etc. Considering any particular sale, tracking code always points to 
the highest level in the scheme. 

You define commission amounts for every possible number of levels, that can occur in 
sales. For example, if you set “Tiers” to 5, buyers can still buy under affiliate at Level 1 or 
Level 2 or Level 3, and for each of these cases you define commission amounts. They do 
not need to sum up to equal amount of total commission, though it's a standard practice.

When number of levels in a particular sale exceeds maximum number of levels in the 
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scheme, it is normally shifted to the right. For example, you have 5-level scheme and 7 
levels in the sale. In this case, affiliates at Level 1 and Level 2 will receive nothing, affiliate
at Level 3 will receive commission defined for Level 1, affiliate at Level 4 will receive 
commission defined for Level 2, etc. You can modify this behavior using “Always include in
commission” drop down box. If you set it to 2, affiliates at Level 1 and 2 will always 
receive commission, while next two level affiliates will receive nothing. In the same case of
5-level scheme and 7 levels in the sale, affiliates receiving commission will be Levels 1, 2, 
5, 6 and 7, while Level 3 and 4 will not get anything.

Zero commission amount (0.00 value in the text box) is allowed.

Commission scheme types can be percentage-based or fixed amount. 

Fixed amount commission is assigned for each product item in the order. For example, if 
order contains of 1 item of Product 1 and 2 items of Product 2 (3 items total), and 
commission is $5, total order commission will be $5 * 3 = $15 . 

If the sum of all commissions exceeds product's price, commission for each level will be 
reduced proportionally. For example, product price is $25, commissions in the 3-level 
scheme are set to $25, $20, $5 ($50 total) – in the order commissions will be $12.5, $10, 
$2.5 ($25 total).

For percentage-based schemes, you can set it to either calculate commission from the 
value defined by General Settings – No Shipping, or from sale's total cost.

New affiliates can be approved automatically or manually, this is configurable per scheme 
per level. OpenCart's own setting for auto-approval is ignored.

Commission can be added to affiliate's accounts automatically when the sale is completed,
or manually in Orders > View > Order Details. This is configurable per scheme per level 
per number of tiers. OpenCart's own setting for auto-adding commission is ignored.

Every scheme has its' own tracking code, which you can attach to affiliate registration URL
by adding &mta=<code>  to the URL. Every new affiliate who signed up with this code 
will be automatically assigned to this scheme. Usually it's not needed, but can be used, for
example, to create special promo actions. For example, you'd like every new affiliate who 
signed up at particular date, to have higher commissions. You create new scheme (with 
higher commissions) and promote registration URL with this scheme's code in it. When the
promo day is over, you copy this scheme to new (with a single click), move all affiliates 
who signed up with it to copied scheme (also with a sinlge click), and then delete the 
original scheme to prevent anyone else from signing up to it.

When no particular scheme is attached to affiliate, product, combination etc., it shows that
the scheme is Default. This means that the scheme which is currently set as Default will 
be used for them, and if you set another scheme as Default, their scheme also changes to
that new default scheme.

Different schemes can be attached to any number of affiliates, products, product + 
discount, product + special, product + coupon,  product + affiliate combinations etc. 
To attach scheme to affiliate, go to Customers > Edit > Affiliate tab.



To attach scheme to product, go to Catalog > Products > Edit. From there, go to Discount
tab to attach schemes to discounts, to Special tab to attach schemes to specials, and to 
Commission tab to attach schemes to product itself and to product + coupon 
combinations. In each of these places, you can also click “Custom Schemes for Selected 
Affiliates”  link to add individual affiliate(s) to the combination. 

Keep in mind that each scheme covers all levels, and each product in the order can use 
one and only scheme. That scheme is selected according to the following system of 
priorities:

– look for product (+ discount / special / coupon) + any of participating affiliates'  
scheme

– if none found, look for product (+ discount / special / coupon) scheme
– if none found, look for any of participating affiliates' scheme (from higher to lower 

level)
– if none found, use Default scheme.

It is very important to understand that Discounts, Coupons and Specials do not inherit 
product's general scheme. If you set custom scheme for a product, and during the sale 
some discount was applied, that custom scheme you've set for the product will not be 
used. The system will look for this particular discount's own scheme (or just use Default).

It is also possible to apply selected scheme, or use it when creating a product:
– for all products by certain manufacturer on Edit Manufacturer page
– for all products in certain category on Edit Category page
– for combinations of all products with certain coupon on Edit Coupon page.

There are several other smaller details. The only one worth mentioning is that logged-in 
affiliates can obtain links with their tracking code, pointing to any page on the site, while 
just browsing the site. Log in as any affiliate to see how it works.

General Settings
Associate customer account with parent affiliate:

Permanently in the database – Even if the customer clears cookies, his association 
with parent affiliate won't be lost. If registered customer uses a link with another affiliate's
tracking code, it will be ignored, affiliate will stay the same. This is default extension's 
behavior.

In cookies only – This uses regular openCart's behavior. If customer clears cookies, 
his orders won't be tracked, and using a link with another affiliate's tracking code will 
replace former affiliate with new one as parent for this customer. Parent Affiliate setting 
on Customer Edit page is ignored.

Permit parent affiliate changing or adding after customer account 
is created:

If set to YES, customer are able to change their parent affiliate (for customer part 
of their account only) by using URL with tracking code at any time, but if set to NO, 
parent affiliate (if tracking code is present) is assigned when they are registering, and can 
only be change in Admin. 

No Shipping:



Each scheme has a YES/NO No Shipping setting. If it's set to NO in the scheme, 
commission will be calculated from order total . If it's set to YES, commission will be 
calculated according to the value defined in this General Setting.

Subtract shipping, handling & taxes from total price – The value will be total with  
shipping, handling, tax and low order fee subtracted from it. It's default.

Ignore all price-increasing modifiers – The value will be subtotal and all totals, which 
decrease it, making it the lowest possible value.

Use subtotal – The value will be subtotal. This is regular openCart 1.5.4 and higher 
behavior. Keep in mind that in certain cases subtotal can be actually higher than total.

Permanently assign default scheme:
When new affiliates sign up with no &mta= code, they are not assigned to any 

particular scheme. Instead, the scheme which is set as Default is used to calculate 
commissions for them. If you set this setting to YES, the scheme that is set as Default 
when affiliate registers will be assigned to them permanently, as if they used that 
scheme's &mta= code . Setting another scheme as Default will not affect them.

You can also:
-  with Tracking Cookie expiration setting, change how long tracking code will last, 

from openCart’s built-in 1000 days, to any number of days, or just one browser session by
setting it to 0 or keeping.

- select one or more Order Status that should trigger Autoadd Commission function.
- configure how the system should handle situations when two or more affiliates in 

the order have different schemes attached to them. Keep in mind that it only resolves 
conflicts on the same priority level – if one affiliate has one scheme attached to product / 
affiliate combination, and the other affiliate has another scheme attached to affiliate, it's 
not a conflict (product / affiliate combination has higher priority).

It's also possible to show affiliates downline tree of all their sub-affiliates on a separate 
page. This function is disabled by default for privacy reasons. If you enable it, affiliates will
have a link to the page with downline tree on their main affiliate account page. You can 
also configure which information (besides names) about sub-affiliates they can see – email
addresses, phone numbers, earnings (total and from last month).
Admin can see complete affiliate downline tree via the link under General Settings, and 
any particular affiliate's downline on Edit Affiliate pages.

Testing
While testing the extension after installing it, you might want to try creating several 
different affiliate accounts and using different affiliate links to make test customer or 
affiliate sign-ups or purchases. If you are going to do this, remember to clear cookies in 
your browser and start new browser session (re-start the browser) every time you are 
going to use new affiliate link, or re-login as different customer.

Admin Insert / Edit Order
When adding order in administration, keep in mind that if Affiliate field is not empty and 
contains different affiliate than customer's current parent, that parent will be replaced. In 
most cases, unless the order is assigned to someone with no customer account, it's better 
to leave Affiliate field empty, the system should be able to find appropriate affiliate.
When you edit existing order in administration, commission also automatically adjust to 
changed data.



For existing orders, both Edit Order and Order Info pages contain a link to Edit Order 
Commission page. On that page you can assign arbitrary commission to any affiliate, 
regardless of their levels, schemes, relations with customer etc., you can also modify 
commission amounts or remove it. Commission is assigned per product. If commission is 
added to affiliate balance already, you have to remove it from balance before modifying 
commission for that affiliate.

If you are using Payment Methods which require manual order completion and still want 
commission to be added automatically, you have to set Order Status to Complete (or any 
other Order Status set to trigger Autoadd in MTA General Settings) using View > Order 
History .

PayPal Express Recurring payments
To pay commission for PayPal Express Checkout Recurring payments , it should be 
enabled in General Settings, and PayPal IPN in your PayPal account must point to the URL 
listed in openCart's Express Checkout payment module settings. Commission amount for 
recurring payments will be in the same proportion to Recurring Profile's price as original 
order commission is to final product price.

Issue with 30+ levels in schemes
Some servers won't save schemes with many (more than 30) defined levels) 
The problem here is not with the extension, but with PHP on the server not configured to 
handle very large forms. 

Generally this can be solved with adding the following to PHP configuration php.ini :
max_input_vars = 10000

But it’s better to consult with your hosting about the issue.



Disclaimer
THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. 
IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR 
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN 
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE.
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